Monday, October 5, 2009

Installing Ruby Gems via a Proxy

On Linux, to install Ruby gems via a HTTP proxy. simply set the HTTP_PROXY (all upper case) environment variable to point to the proxy.

For example:

export HTTP_PROXY=http://my.proxy.server:port/
gem install sproutcore

Update: Brat points out that FTP_PROXY may also be required for FTP access. For example:

export FTP_PROXY=http://my.proxy.server:port/

Saturday, October 3, 2009

SproutCore 1.0

SproutCore SproutCore is a HTML5 Application Framework written in JavaScript, that makes it easy to use HTML5 features across the browsers. At the Silicon Valley Code Camp this year, Charles Jolley from Sprout gave a great presentation about the features of SproutCore and did an excellent demo of a simple HTML5 ToDo app that runs using the Google App Engine. Seems like a very interesting framework to take advantage of HTML5.

Gentoo and KDE

I've been using Gentoo since early 2003 and have generally been very regular (almost daily, at least weekly) with system updates using emerge. There was a period of time though when the system was on KDE 3.x and I didn't do any updates for several months. Eventually it took me a lot of effort to resolve dependencies and fix the blocked packages to go up to KDE 4.1. Being an old machine, I didn't do much on that system for the past 5 months. Now it seems like it's going to be very very difficult to any updates.

Running emerge -av kde-meta:4.3 give me a huge number of conflicts and blocked package:

Total: 290 packages (26 upgrades, 59 new, 205 in new slots, 228 uninstalls), Size of downloads: 556,992 kB
Conflict: 272 blocks (12 unsatisfied) ('installed', '/', 'x11-libs/qt-svg-4.5.0', 'nomerge') pulled in by
~x11-libs/qt-svg-4.5.0 required by ('installed', '/', 'x11-libs/qt-4.5.0', 'nomerge')

('ebuild', '/', 'x11-libs/qt-dbus-4.5.2', 'merge') pulled in by
>=x11-libs/qt-dbus-4.4.0:4 required by ('ebuild', '/', 'media-sound/phonon-4.4_pre20090520', 'merge')
x11-libs/qt-dbus:4 required by ('ebuild', '/', 'dev-libs/soprano-2.3.1', 'merge')
x11-libs/qt-dbus:4 required by ('installed', '/', 'app-misc/strigi-0.6.4', 'nomerge')
(and 2 more)

('ebuild', '/', 'x11-libs/qt-svg-4.5.2', 'merge') pulled in by
>=x11-libs/qt-svg-4.5.1:4 required by ('ebuild', '/', 'kde-base/kleopatra-4.3.1', 'merge')
>=x11-libs/qt-svg-4.5.1:4 required by ('ebuild', '/', 'kde-base/kwallet-4.3.1', 'merge')
>=x11-libs/qt-svg-4.5.1:4 required by ('ebuild', '/', 'kde-base/nepomuk-4.3.1', 'merge')
(and 232 more)
...

Gentoo systems have always had problems when upgrades are not done frequently but right now it looks like the system is un-upgradeable.

Any quick fix solutions here? I already run Kubuntu, Open SuSE and Enterprise Linux on other systems. So I'm aware of other common Linux distro choices but I'd like to get the Gentoo system back to the latest in Portage.