Saturday, October 3, 2009

Gentoo and KDE

I've been using Gentoo since early 2003 and have generally been very regular (almost daily, at least weekly) with system updates using emerge. There was a period of time though when the system was on KDE 3.x and I didn't do any updates for several months. Eventually it took me a lot of effort to resolve dependencies and fix the blocked packages to go up to KDE 4.1. Being an old machine, I didn't do much on that system for the past 5 months. Now it seems like it's going to be very very difficult to any updates.

Running emerge -av kde-meta:4.3 give me a huge number of conflicts and blocked package:

Total: 290 packages (26 upgrades, 59 new, 205 in new slots, 228 uninstalls), Size of downloads: 556,992 kB
Conflict: 272 blocks (12 unsatisfied) ('installed', '/', 'x11-libs/qt-svg-4.5.0', 'nomerge') pulled in by
~x11-libs/qt-svg-4.5.0 required by ('installed', '/', 'x11-libs/qt-4.5.0', 'nomerge')

('ebuild', '/', 'x11-libs/qt-dbus-4.5.2', 'merge') pulled in by
>=x11-libs/qt-dbus-4.4.0:4 required by ('ebuild', '/', 'media-sound/phonon-4.4_pre20090520', 'merge')
x11-libs/qt-dbus:4 required by ('ebuild', '/', 'dev-libs/soprano-2.3.1', 'merge')
x11-libs/qt-dbus:4 required by ('installed', '/', 'app-misc/strigi-0.6.4', 'nomerge')
(and 2 more)

('ebuild', '/', 'x11-libs/qt-svg-4.5.2', 'merge') pulled in by
>=x11-libs/qt-svg-4.5.1:4 required by ('ebuild', '/', 'kde-base/kleopatra-4.3.1', 'merge')
>=x11-libs/qt-svg-4.5.1:4 required by ('ebuild', '/', 'kde-base/kwallet-4.3.1', 'merge')
>=x11-libs/qt-svg-4.5.1:4 required by ('ebuild', '/', 'kde-base/nepomuk-4.3.1', 'merge')
(and 232 more)

Gentoo systems have always had problems when upgrades are not done frequently but right now it looks like the system is un-upgradeable.

Any quick fix solutions here? I already run Kubuntu, Open SuSE and Enterprise Linux on other systems. So I'm aware of other common Linux distro choices but I'd like to get the Gentoo system back to the latest in Portage.


Rainman said...

I think I know what the problem is. I think most of your libraries (X11, for instance), are built using QT. Since you haven't upgraded in ages, you were probably running Qt 4.3.1 or something, and since then, a lot has changed. These logs seem to indicate that QT 4.5.1 is required, which means a whole bunch of chained dependencies. Another problem is that somewhere along the way, Trolltech (makers of QT) got bought my Nokia, and as a result, I don't think the libraries are available for download anymore, on their site. I don't see a pain-free upgrade, unless you want to dig deep and resolve dependencies manually. Its probably not worth the effort anyway :-)

Rainman said...

Have you tried getting QT libraries at tips?

Anonymous said...

Yes, I was running at the 4.3.1 level. The way Gentoo works, it tries to pull in the latest ebuild anyway (except for masked ebuilds) which is fairly close to tip. I think I have to first unmerge all the packages that depend on QT or KDE ... which is a pain!

Rainman said...

Agreed - it is a pain! Looks like you might have to wipe out, and start afresh :-)